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Introduction  

In October 2012, subject matter experts from several federal agencies developed an Accessible 

Electronic Document Community of Practice (AED COP) with the goal of improving accessible content, 

advancing the field of accessibility, and creating accessible artifacts reusable across many agencies. 

This document contains the minimum requirements to test whether a PDF document is Section 508 

accessible and acceptable for posting to a website. This information includes how to inspect your PDF 

using Adobe Acrobat XI professional.  

This document does NOT contain information on how to author accessibly. However, it is a best 

practice to test your source document in the authoring tool (such as MS Word or Adobe InDesign) 

prior to testing the PDF in Adobe Acrobat XI Professional. For other AEDCOP Section 508 Basic 

Authoring and Testing Guides, visit http://www.section508.gov/content/learn/best-practice-library. 

Federal agencies and other institutions create millions of documents each year. Making documents 

accessible is important so that individuals with disabilities can access information. Individuals with 

disabilities may include, but are not limited to: Blind or Low Vision, Deaf or Hard of Hearing, Physical 

Disability and Intellectual Disability. 

Assistive technology (AT) is used by individuals to help them understand electronic information. For 

example, screen readers or text-to-speech software is one tool available and assists individuals who 

are blind, have low vision, or a learning disability. This technology interprets words on the page and 

translates them to a computerized voice that reads the information. Accessible documents work in 

partnership with assistive technology to ensure individuals with disabilities have access to 

information.  

As you share your PDF document, it might be helpful to think about the concept of comparable 

access. When you adhere to the following accessibility requirements, you are providing a document 

that allows individuals with disabilities 1) to access the important information that you are publishing 

and 2) to gain access to information in a comparable way as their non-disabled peers. 

The current version 0.1 is draft. Please send review comments and feedback to 

Holly.Anderson@ed.gov.  

This document is devided into the following 6 categories: 

 Preconditions 

 Document Properties 

 Structure Tags  

 Objects 

 Color  

 Miscellaneous 

This document does NOT cover: 

 PDFs produced from Adobe LiveCycle (See Precondition B) 

 PDFs without Tags (See Precondition C) 

mailto:Holly.Anderson@ed.gov
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 PDFs with Scripts (See Precondition D) 
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Preconditions 

A. PDF Portfolio 

A PDF Portfolio is a collection of documents combined into one PDF file. Collections may include a 

variety of document types, like PDF and MS Word. Each document must be tested separately and 

with the appropriate test process. 

Inspect The PDF 

1) Open the PDF file. 

2) If there is more than one document as shown in Figure 1, open each document separately. 

3) Test each document with the appropriate test process as listed in Table 1. 

Figure 1: Example PDF portfolio 

 

Table 1: AEDCOP recommended test process listed by file type 

File Type Recommended Test Process 

.pdf AEDCOP Section 508 Basic Testing Guide (Current Document) 

.docx AEDCOP Section 508 Basic Authoring and Testing Guide MS Word 2010 
AEDCOP Section 508 Basic Authoring and Testing Guide MS Word 2013 

.pptx AEDCOP Section 508 Basic Authoring and Testing Guide MS PowerPoint 2010 
AEDCOP Section 508 Basic Authoring and Testing Guide MS PowerPoint 2013 

.xlsx AEDCOP Section 508 Basic Authoring and Testing Guide MS Excel 2010 
AEDCOP Section 508 Basic Authoring and Testing Guide MS Excel 2013 

.htm* Department of Homeland Security (DHS) Trusted Tester Process 
 URL: http://www.dhs.gov/compliance-test-processes  

http://www.dhs.gov/compliance-test-processes


Preconditions 

Section 508 Basic Testing Guide – PDF   6 

 

B. Adobe LiveCycle  

You cannot verify the accessibility of Adobe LiveCycle documents in Adobe Acrobat Professional. 

Inspect The PDF 

1) Open Document Properties (File > Properties > Description).  

2) If the PDF Producer is Adobe LiveCycle, then use the AEDCOP Section 508 Basic Authoring and 
Testing Guide Adobe LiveCycle. 



Preconditions 
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Figure 2: Document properties for an Adobe LiveCycle document 



Preconditions 
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C. Tagged PDF 

To check for Section 508 accessibility, the document must be a “Tagged PDF.” 

Inspect The PDF 

1) Open Document Properties (File > Properties > Description). 

2) If you find “Tagged PDF: No,” return the document to the author with reference to the AEDCOP 
Section 508 Basic Authoring Guides. 

Figure 3: Document properties for a PDF without tags 
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D. Scripts  

Adding programming (Scripts) to a document effectively turns it into a software application. Software 

applications should be tested using software testing methods.  

Inspect The PDF 

1) Run the Accessibility Full Check (View > Tools > Accessibility >Full Check > Start Checking). 

2) Expand the “Page Content” category to view issues. 

3) If you find “Scripts – Needs manual check,” then test with the Department of Homeland Security 
(DHS) Trusted Tester Process located at: http://www.dhs.gov/compliance-test-processes. 

Figure 4: Accessibility Full Check results for a PDF with scripts 

 

http://www.dhs.gov/compliance-test-processes
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E. Scanned Document 

Because of software limitations, scanned documents require additional steps to ensure accessibility.  

If you need to distribute a scanned document, then first consult your agency’s scanned document 

policy. 

Inspect The PDF 

1) Run the Accessibility Full Check ( View > Tools > Accessibility >Full Check > Start Checking). 

2) Expand the “Document” category to view issues. 

3) If you find “Image-only PDF – Failed,” then consult your agency’s policy. 

Figure 5: Accessibility Full Check results for a scanned document 
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Document Properties 

1. Scanned Pages 

All or part of a PDF may be compiled from scanned pages. When you see a scanned page, you are 

actually looking at a picture of the original page. Screen readers cannot infer meaning from just a 

picture, so these pages must be accompanied by text. Optical Character Recognition software may be 

used to recognize the text in the PDF and embed this text into the page. Make sure the texts match. 

Inspect The PDF 

1) Look for any scanned pages (pages that are pixilated, blurry, or have low resolution, etc). 

2) Save the document as a text file (File>Save As Other>More Options>Text). 

3) Open the text file. 

4) Check that the text in the text file and the text in the PDF file match. 

Figure 6: Comparison of a text file to a scanned page in a PDF 
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2. Descriptive Filename 

A descriptive filename that identifies the document or its purpose helps everyone (including people 

with disabilities) locate, open, and switch between documents. 

Inspect The PDF 

1) Open document Properties (File > properties > Description). 

2) Check that the filename identifies the document or its purpose. 

Figure 7: Document properties for a PDF with a descriptive filename 

  

Table 2: Examples of nondescriptive and descriptive filenames 

Nondescriptive Filename Descriptive Filename 

Untitled1.pdf OMBReport387_2102014_v2.pdf 

Document!.pdf Chapter6FY2016Justification.pdf 

Presentation1.pdf 2015Security_Training.pdf 
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3. Assistive Technology Access  

Security settings can prevent users from changing content and enable features, like saving form 

data; however, these security settings may block AT access to content. 

Inspect The PDF 

1) Open Document Properties (File > Properties > Security). 

2) Check that “Content Copying for Accessibility” is “Allowed” as shown in Figure 8. 
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Figure 8: Document properties for a PDF that allows content copying for accessibility 
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4. Document Language 

Screen readers access the language setting in Document properties to provide the appropriate 

pronunciation for the document. 

Inspect The PDF 

1) Identify the main language in the document. 

2) Open Document Properties (File > Properties > Advanced). 

3) Check that the “Language” setting matches the main language of the document. 
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Figure 9: Document properties for a PDF with English as the main language 
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Structure Tags 

5. Tags 

Screen readers rely on tags to interpret the document structure (headings, paragraphs, lists, images, 

data tables, forms, and other objects. All meaningful text and objects must correspond to a tag and 

the order of tags must follow the visual/logical order. 

Inspect The PDF 

1) Open the Tags pane (View > Show/Hide > Navigation Panes > Tags). 

2) Press Ctrl and left click on the plus symbol to expand all tags. 

3) Select a tag to highlight the corresponding content on the page. 

If you do not see the light blue highlighting, then turn on “Highlight Content” (Tags Pane > 
Options > Highlight Content). 

4) Press Ctrl + A to select all tags.  

5) Check that all meaningful text and objects are highlighted.  

6) Use the up and down arrow keys to move through the tags. 

7) Check that the tags follow the visual/logical order on the page. 

Figure 10: Example of tags that follow the visual/logical order 
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6. Decorative Content 

Decorative content should be set to Artifact, so screen readers can skip over ornamental images and 

redundant text. 

Inspect The PDF 

1) Open the Tags pane (View > Show/Hide > Navigation Panes > Tags). 

2) Right click on the Tags Pane and select “Find.” 

3) In the Find Element window, select “Artifacts,” “Search Document” and then “Find,” This will 
highlight an Artifact on the page. Press “Find Next” to find all Artifacts in the document. 

4) Check that decorative text and objects are set to Artifact. 

Figure 11: Example of decorative content that is set to artifact 
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5)  

7. Headers, Footers &Watermarks 

Vital information in headers, footers or watermarks must correspond to a tag at or near the start of 

the related information or screen readers will skip over it. 

Inspect The PDF 

1) Look for vital information in headers, footers and watermarks. 

2) Go to the first page to which the information applies, like the start of the document or section. 

3) Open the Tags Pane (View > Show/Hide > Navigation Panes > Tags). 

4) Use the mouse to select the running header, footer, or watermark.  

5) Find the corresponding tag (Tags Pane > Options > Find tag from selection). 

6) Use the up and down arrow keys to move through the tags. 

7) Check that vital information is located at or near the start of related information in the Tags Pane. 

Figure 12: Example of vital information located at the start of the related 
information
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8. Headings 

Headings are used to break-up content and make finding information easier. AT cannot infer meaning 

from just formatting, like bold or underline, so 

1) Visual headings must correspond to a heading tag and 

2) Heading tags  must match the visual outline. 

Inspect The PDF 

1) Look for headings (such as the title of the document or topics that start new sections).  

2) Open the Tags Pane (View > Show/Hide > Navigation Panes > Tags).  

3) Use the mouse to select a heading. 

4) Find the corresponding tag (Tags Pane > Options > Find tag from selection). 

5) Check that headings correspond to heading tags (<H1>, <H2>, <H3>, <H4>, <H5> or <H6>). 

If you find nonstandard PDF tags, like <Head1> or <MainHeading>, you will also have to open 
the Role Map (Tags Pane >Options > Edit Role Map), and expand Document Roles to check that 
the nonstandard tags are mapped to the standard heading tags listed above. 

 

6) Check that heading levels 1, 2, 3, 4, 5, and 6 match the visual outline level. 
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Figure 13: Example of headings that match the Visual Outline 



Structure Tags 

Section 508 Basic Testing Guide – PDF   22 

 

9. Lists 

Screen readers cannot infer meaning from just symbols and indents.  List tags create a structure that 

screen readers can identify. 

Inspect The PDF 

1) Find bulleted, numbered, and multilevel lists. 

2) Open the Tags Pane (View > Show/Hide > Navigation Panes > Tags). 

3) Use the mouse to select a whole list.  

4) Find the corresponding tags (Tags Pane > Options > Find tag from selection). 

5) Check that: 

 Lists correspond to a list tag (<L>), 

 List items correspond to list item tags <LI>, and  

 <LI> are nested under <L>. 

Figure 14: Example of the correct list structure 
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10. Section Language 

When the language of a paragraph differs from the Document Language (p.15), screen readers 

access the language in Tag Properties to provide the appropriate pronunciation for the section. You 

do not have to check the language for proper names, technical terms, or foreign words that have 

become part of the vernacular. 

Inspect The PDF 

1) Identify any sections that differ from the Document Language. 

2) Open the Tags Pane (View > Show/Hide > Navigation Panes > Tags). 

3) Use the mouse to select a section.  

4) Find the corresponding tag (Tags Pane > Options > Find tag from selection). 

5) Open the Tag Properties (Alt + Enter > Tag >Language). 

6) Check that the value matches the language or “Codes for the Representation of Names of 
Languages” found at http://www.loc.gov/standards/iso639-2/php/English_list.php.  

http://www.loc.gov/standards/iso639-2/php/English_list.php
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Figure 15: Example of a PDF with section languages identified in Tag Properties 
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Objects 

11. Images 

Screen readers cannot infer meaning from images and other objects (pictures, images of text, charts, 

diagrams, shapes, icons with hyperlinks, etc). Meaningful images must be accompanied by text that 

describes the purpose or function. 

Inspect The PDF 

1) View Figures (Tools > Accessibility > TouchUp Reading Order). Check “Show tables and figures.” 

2) Look for text descriptions on meaningful images and objects. 

 For images marked by “Figure” such as Figure 16, right click and select “Edit Alternate Text.” 

 Examine any caption associated with the image for a text description as shown in Figure 17. 

 Examine the surrounding content for text that describes the image and other objects. 

3) Check that the descriptive text conveys the purpose and/or function of the image or object. 

4) For images of text, check that the descriptive text matches verbatim. 

Figure 16: Image marked with “Figure” 

 

Figure 17: Image with caption 
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12. Data Tables 

In data tables, header cells are required to describe the data. For AT to interpret this information: 

1) Data tables must correspond to a table tag <Table>. Images of data tables are not accessible. 

2) Header cells must be identified with table header cell tags <TH>. 

3) Complex data tables must have data cells associated with headers cells. 

Inspect The PDF 

1) View Tables (Tools > Accessibility > TouchUp Reading Order). Check “Show tables and figures.” 

2) Check that all data tables are identified with “Table” on the page as shown in Figure 18. 

3) Open the Table Editor. Select the number on the Table > Touch Up Reading Order > Table Editor.  

4) Right click on the table > Table Editor Options > Check  “Show cell type” (TH or TD). 

5) Check that table header cells are marked with “TH” and data cells with “TD” as in Figure 19. 

Figure 18: A data table marked  
as “Table” and not  “Figure” 

 

Figure 19: Table header cells are marked with “TH” and  
table data cells are marked with “TD” 

 

6) For complex tables like Figure 20, right click on each table cell and select Table Cell Properties.  

7) For header cells, check for ID and that scope, row span, and column span match the visual layout 
as shown in Figure 21. 

8) For data cells, check that Associated Header Cell IDs are included as shown in Figure 22. 

Figure 20: Example of a complex data table  
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Figure 21: Table cell properties for a header cell 

 

Figure 22: Table cell properties for a data cell 

 

13. Links and Controls 

Links and controls must be: 

1) Uniquely identified  

2) Described with the destination, function, and/or purpose in the name or within context. 

3) In a tab order that matches the visual/logical order of interactive elements (links, controls, and 
form fields).  

Inspect The PDF 

1) Press the Tab key to find links and user controls. 

2) Check that each link has an unambiguous name that describes the destination, function, and/or 
purpose OR that this is determinable within context as shown in Table 3. 

3) If an image is a link or user control, then the alt-text can contain the link purpose, function or 
destination (See 11. Images, p.25). 

4) Check that the tab order matches the visual/logical order of links. 

Table 3: Examples of Link Names 

Uniquely Named Link: …additional details are available on OPM.gov. 

Links Determinable within Context:  Further details are listed in the Company 
Annual Report. 

Ambiguous Links Not Determinable Within Context: Click here / Click here for information about 
each topic. 

 

http://www.opm.gov/
http://www.doohanda.com/
http://www.doohanda.com/
http://www.doohanda.com/
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14. Forms 

In order to correctly and accurately complete a form, it is necessary to follow instructions, directions 

and cues, as well as enter information in the correct fields. For AT: 

1) Each form field must have a tooltip and  

2) the tab order must match the visual order. 

Inspect The PDF 

1) Press the Tab key to find form fields (text fields, radio buttons, checkboxes, combo boxes, etc). 

2) Hover over each form field to reveal the tooltip. 

3) Check that the tooltips match the label or instructions. 

4) Check that the tab order matches the visual/logical order of form fields. 

Figure 23: Example of a text field with a tooltip 
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Color 

15. Color and Other Sensory Characteristics 

Sensory characteristics (such as color, size, shape, and location) must include text to convey 

meaning. Without text, individuals who are blind, low vision, or color blind will not have access to 

comparable information.  

Inspect The PDF 

1) Find color and other sensory characteristics. 

2) Check that there is text that conveys the meaning of color or sensory characteristics. 

Figure 24: Inaccessible example 

Project Status 

A  

B  

C  

D  

E  

F  

G  

 

Figure 25: Accessible example 

Project Status 

A late 

B at risk 

C at risk 

D on time 

E late 

F  on time 

G on time 
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16. Color Contrast 

Having a high level of contrast between foreground and background results in more people being 

able to see and use the content. The required standards are listed in Table 4. 

Table 4: Color contrast ratios by text size or type 

Type or Size of Text   Contrast Ratio 

Standard 4.5:1 

Large Text (14 pt bold or 18 pt regular) 3:1 

Incidental text, text overlaid on images, and logotypes Excluded from requirement 

Inspect The PDF 

1) Download the color contrast analyzer. You can run the application without installing it onto your 
computer.  

2) Drag the Foreground eyedropper icon over a sample of your text or image of text.  

3) Drag the Background eyedropper icon over a sample of your background color.  

4) Check that the color contrast ratio passes (AA) in the Color Contrast Analyser.  

Figure 26: Example of text that passes the color contrast analyser 

 

 

 

http://www.paciellogroup.com/resources/contrastAnalyser
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Miscellaneous 

17. Audio, Video and Multimedia 

Audio-only, video-only or multimedia objects that contain meaningful information must have aditional 

text and/or descriptions, so that individuals with disabilities have comparable access to the content. 

Inspect The PDF 

1) Activate the meaningful audio-only, video-only or multimedia object. 

2) For audio-only, check that the transcript is accurate and complete. 

3) For video-only, check that the text description is accurate and complete. 

4) For multimedia (audio and video), check that the synchronized captions and audio description are 
accurate and complete. 

Table 5: Additional information required listed by object type 

Type Also include: What is this? 

Audio-only  Accurate and complete 
transcript  

A transcript is a text version of exactly what is being 
said in the audio-only file. 

Video-only Accurate and complete text 
description 

A description is a text version of what is being shown 
in a video-only file. 

Multimedia  
(audio and 
video) 

Accurate, complete, and 
synchronized captions and 
audio descriptions 

Captions are time-synchronized text version of 
exactly what is being said and/or a description of the 
relevant sounds in the multimedia file. 
Audio descriptions are time-synchronized 
descriptions of what is being shown in the 
multimedia file. 

 

18. Flashing Objects 

Federal agencies do not typically see flashing objects embedded into documents. Since flashing 

objects may be a public safety issue for individuals with photosensitive epilepsy and there is not 

typically a compelling business need, flashing objects should be excluded. If you feel you do have a 

compelling business need, please contact the AT Team for assistance in ensuring your object flashes 

below 3Hz.  

19. Alternative Accessible Version 

Federal agencies have the goal to produce one accessible document for everyone. However, there 

may be times when this is not feasible. Therefore, it is recommended that you contact the AT Team 

to ensure an alternative version is necessary as you are still required to create an alternative version 

that is accessible, up-to-date and has equivalent content. 


